
Edgeworth’s simplification was this
assumption: every man [person] is
a pleasure machine.

Robert Heilbroner

Maximizing Utility

Figure 6.1: Computer generated image of cigars and brandies.
Source: https://stablediffusionweb.com/
Prompt: cigars and brandies on a table
Date Generated: October 5, 2023

Figure 6.1 shows two things, cigars and brandies, that we will pretend that
you enjoy. Economists model the satisfaction and happiness provided by
consumption of goods and services by using a utility function.

Your utility function is given by this equation:

U = 18B − 3B2 + 20C − C2

Your job is to choose the number of brandies (B) and cigars (C ) that maxi-
mize your utility (U ).
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This optimization problem can be solved analytically, with calculus and al-
gebra, but we will use Excel’s Solver instead. As you recall, Solver is a
numerical approach to finding the optimal solution.

We need to recast the problem in a way that Excel can understand it, then
run Solver to find the optimal values of B and C.

The work below assumes that you have done the Lifeguard Problem (an ear-
lier chapter in this book) and remember some of it. If you have not, you
can continue working, but you will learn more if you review the Lifeguard
Problem before you begin this material.

Implementing the Problem in Excel

Optimization problems always have three parts:

1. Goal (objective function)

2. Endogenous variables

3. Exogenous variables

We know we want to maximize the utility function so that is our goal. It has
to be a formula in a cell that depends on other cells in the spreadsheet.

Your endogenous, or choice, variables are B and C. We implement this part
of the problem with cells that Solver will use for trial solutions. In the Solver
dialog box, these are called the changing cells.

Finally, the exogenous variables are things the decision-maker cannot change.
They are part of the environment. In this problem, your exogenous variables
are the coefficients (18, - 3, 20, and -1) and exponents in the utility function.
We could set up cells for these exogenous variables, but we will keep things
simple and just enter the utility function as is.

STEP Open a blank Excel workbook and save it as UtilityMax.xlsx. In
cell A1 enter a 1 and in cell B1 enter the label Brandies. In cell A2 enter a 1
and in cell B2 enter the label Cigars. In cell A4 enter the formula =18*A1-
3*A1ˆ2+20*A2-A2ˆ2 and press the enter key.
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Excel displays 34 in cell A4 because if you smoke one cigar and sip one
brandy, your utility function says that you get 34 utils of satisfaction. Now,
there is no such thing as a util, but we will ignore this inconvenient truth.

STEP Change cell A1 to 2.

Your utility rises to 43 utils. This is an improvement in your happiness, but
you do not want to simply improve, you want to maximize utility. What are
the best values of B and C, the ones that make utility the largest number
possible?

Solving the Problem in Excel

Once we have implemented the problem in Excel, with a formula for the
objective function that depends on other cells, we can utilize Solver. It will
explore the objective function, trying many solutions. It follows an algo-
rithm, or recipe, when deciding where to move next.

There are many different optimization algorithms. Sometimes, one fails, but
another works. Some are good for several different kinds of problems and
others are only useful for specific applications. There is no one single algo-
rithm that is better than the others.

STEP Open the Solver dialog box by clicking the Data tab and clicking
Solver. If it is not there, use the keyboard shortcut alt, t, i to bring up the
Add-ins Manager and install it. Click in the objective function field, click
on cell A4, click in the Changing variable cells field, and select both A1 and
A2. Click Solve. Click OK when Excel displays a dialog box reporting that
it has found a solution.

Solver’s answer is really close to the exact solution, which is to drink 3
brandies and smoke 10 cigars. This yields a utility of 127. You may not
believe it, but you will see below that it is impossible to get utility higher
than 127.

Remember that Solver is hunting and pecking, plugging and chugging through
many trial solutions. It changes direction when it does worse and continues
forward when it is doing better. It stops when it does not improve by very
much. Hence, it sometimes gets the exact right answer, but mostly it just
gets very close.
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STEP Let’s make sure it is clear that Solver’s answer is not exactly
right by widening column A and displaying more decimal points until you

see a few zeroes (click the Increase decimal button repeatedly in Number
group in the Home tab).

Your screen should look similar to Figure 6.2. We would never report all
of those digits because they are meaningless and exhibit false precision. We
interpret Solver’s answer as B* = 3 and C* = 10 and U* = 127, which is the
correct answer.

Figure 6.2: Solver results.

Displaying the Optimal Solution

To visualize the optimal solution, we first use a 3D Surface chart. In the
next section, we will create a 2D graph since economists and mathematicians
often use contour plots to display two-variable optimization problems.

To create a chart in Excel, we need data. The 3D chart requires a specific
layout, with the x axis in a row, the y axis in a column, and the z (vertical)
axis in the interior of the table.

STEP In cells D2 to D12, enter 0 to 10 by 1. In cells, E1 to Y1, enter
0 to 20 by 1. These are the two horizontal axes in our 3D plot. In cell E2
enter the formula: =18*$D2-3*$D2ˆ2 + 20*E$1-E$1ˆ2.

Notice how the $ is being used. We are going to fill this formula down and
then right. When we fill it down, it will change the row number for the
brandies and continue to use row 1 for the cigars part of the utility function.
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STEP Fill your formula in E2 down and then examine the formulas in
cells E3 and E12 to confirm that the row number is changing for column D,
but stays constant at 1 for column E.

STEP Select cells E2 to E12, then fill right. Examine the formulas in
cells Y3 and Y12 to confirm that column D stays constant, but the cigars
part of the utility function has changing columns.

Our clever use of the $ has enabled us to create a table that shows how utility
varies with changing amounts of brandies (in column D) and cigars (in row
1). The interior of the table displays values of utility.

It is easy to see that the maximum utility value is in cell O5. It is surrounded
by lower values. Solver reached the top of this hill by crawling up until it
got to the top, at 3 brandies and 10 cigars.

STEP Select cell O5 and make its background color yellow by clicking
the bucket icon in the Font group in the Home tab.

We are now ready to create a chart. As you know, there are three steps: 1)
Select the data, 2) choose the desired chart type, and, perhaps most impor-
tant, 3) clean up the chart.

STEP Select range D1 (notice that this cell is empty, but you need
to select it to get all of the rows and columns in the table) to Y12. Click
the Insert tab and click Recommended Charts. Click All Charts and click
Surface. Click 3-D Surface and click OK.

Excel places a chart that looks like an elongated hill on your spreadsheet. It
decided to put cigars (in row 1) on the x axis because it has more cells, but
this is not what we want. We need to clean up this chart.

The first thing to do is to put the brandies axis in the front and the cigars
on the side.

STEP Click the Design tab (if needed) and click the Switch Row/Column

button.

That looks much better, but we have more cleaning up to do.
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STEP Remove the legend (select it and press the delete key) and add

axes titles for each axis. Click the Add Chart Element button and select
Axis Titles. Use Brandies for the Primary Horizontal title, Cigars for the
Depth title, and Utility for the Primary Vertical title. Change the chart title
field text to Utility Maximization.

It is now really looking like something we would be proud to put our name
on, but we can do one final improvement: add more color bands to clearly
see that it is a hill.

STEP Double-click the Utility axis to bring up the Format Axis: Axis
Options screen on the right. Change the Major Units field from 50 to 10.

Your chart now looks like Figure 6.3. The crowded numbers on the Utility
axis are not great, but the extra color bands make it easy to see that there
is a clear top to this surface.

Figure 6.3: A 3D visualization of utility maximization.

6



Contour Plot

Although a 3D plot like Figure 6.3 is useful, solutions to optimization prob-
lems with two endogenous variables often use a 2D, contour plot that high-
lights the choice variables.

A contour plot, also called a level curve, displays a 3-dimensional surface
by graphing constant vertical slices of the surface, called contours, on a 2-
dimensional chart. It is easier to see what it is than to describe it.

STEP Copy the 3D chart you just made and paste it. In the Design

tab, click the Change Chart Type button. Click the Contour Plot type

(with the shaded region that signals the use of color) and click OK.

Comparing the color bands on the two charts makes clear how they are re-
lated. The light blue at the top of the hill in the 3D plot is the light blue
oval in the contour plot. The orange band is a little lower on the hill and it
is a bigger oval on the contour plot.

It is as if you flew on a plane and looked straight down at the hill. The
vertical axis is suppressed on the contour plot, but we could put labels with
numbers of the vertical height on each slice. This is exactly what a topo-
graphic map does.

STEP Use your favorite browser to search for “contour plot hiking
map”. Click on a few hits to see how 2D maps can show elevation by dis-
playing numbers on each contour. If you walked on a specific contour, you
would never go up or down.

Contour plots are also used on weather maps. Isobars are contour plots show-
ing the same atmospheric pressure.

Let’s clean up Excel’s contour chart by improving the title and moving the
y axis from right to left.

STEP Click on the title and make it Utility Maximization: Contour
Plot. Double-click the y axis and change the Label Position to High as
shown in Figure 6.4.
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Figure 6.4: Moving the y axis from right to left.

A final enhancement involves placing a point on the optimal solution and
labeling it with a callout box (in the Shapes collection in the Insert tab), as
shown in Figure 6.5.

Figure 6.5: A 2D contour plot of utility maximization.
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Comparing the 3D and 2D visualizations of this utility maximization prob-
lem reveals advantages of each. The 3D version makes clear that the surface
is a hill with a maximum, but it is difficult to read the optimal number of
brandies and cigars.

On the other hand, the 2D contour plot makes it really easy to see the max
and the values of brandies and cigars that will maximize utility. The trick is
that you have to know how to read a contour plot and now you do.

Make It Stick

If we used Solver earlier when we did the Lifeguard Problem, why are we do-
ing it again? Repeating material is a learning strategy that has been proven
to work.

Suppose you want to improve your free throw shooting and you really cared
about this so you decided to practice for one hour per day for two weeks.
Most people would think that actually standing at the free throw line and
shooting free throws would be the best use of your time, but this is wrong.

A much better use of your one hour per day is to shoot from all over the
court—spending 10 minutes in one spot, then moving to another spot, vary-
ing distance from say 10 to 20 feet (a free throw is 15 feet from the basket).
This is called interleaved practice and it works also for learning!

By doing the Lifeguard Problem, then doing other things and returning to a
slightly different optimization problem, you are burying deeper channels in
your brain about Solver and optimization.

Every time you repeat something in Excel, especially in the context of a dif-
ferent situation, you get a little better at it. The novelty of the new problem
is important so that you are not doing the exact same thing, but you are
making connections and learning.

If you want to know more about the neuroscience behind how you learn and
other optimal learning strategies, search for Brown, et al.’s 2014 book, Make
It Stick .

STEP Watch tiny.cc/howtostudy to see some of these ideas applied to
optimal studying.
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Takeaways

We revisited work we did earlier, using Solver, Excel’s numerical optimiza-
tion add-in.

Excel’s Solver easily found the optimal solution to a simple two-variable util-
ity maximization problem.

Solver applies an iteration procedure and stops when it cannot improve by
very much. This produces an answer that is not exactly correct, even though
the many decimal places it reports seem like it is giving a really precise
answer, a phenomenon common to numerical algorithms known as false pre-
cision.

Two Excel chart types were used to visualize the optimal solution: 3D sur-
face and contour plot.

The 2D contour plot is the best-practice way to display the problem because
it highlights the two endogenous variables (one on each axis) and makes it
easy to see the numerical values of the optimal solution.

Learning also involves optimization, with better and worse ways to use your
time. You definitely want to study and learn optimally.

References

The epigraph is from p. 173 of the 7th edition of Robert Heilbroner’s The
Worldly Philosophers. First published in 1953, this classic tells the story of
how economics was born and came to be the mathematical discipline that
it is today. It is an easy read and until Freakonomics (by Stephen J. Dub-
ner and Steven Levitt) exploded on the scene in 2009, Heilbroner’s Worldly
Philosophers had the highest sales of any economics book.

Francis Edgeworth was a key player in the mathematization of economics.
Mathematical Psychics, published in 1881, was an early application of opti-
mization and comparative statics.

Brown, P., Roediger III, H., and McDaniel, M. (2014) Make It Stick: The
Science of Successful Learning (Belknap Press).

10


	Maximizing Utility

